IssuesCategory: MagioThe problem occurs with Magio_Mesh,Magio_SkinnedMesh
Takashi Ishida asked 2 months ago

– Unity Rendering Pipeline:URP
– Unity Editor Version:2022.3.4f1
– Visual Effects Graph version:14.0.8
– Problem/Error messages
When I install Magio Pro in the above environment and play the sample scene, I get the following error message I have tried re-importing Magio, but it still occurs.
This is why the flame and diffusion effects do not work.
“IF you are getting this error when importing Magio for first time, Please install Visual Effects Graph and Re-import Magio Folder (Right-click->Re-import). Otherwise: Effect invalid for Meshes. Please check that your effect has property called Magio_Mesh”

TAKASHI ISHIDA replied 2 months ago

I did right click -> re-import. Still no solution. Problem Magio_Mesh,Magio_SkinnedMesh
These exist in the demo scene prefab.
It is the demoscene prefab that is causing the problem, not the prefab I created.

1 Answers
Thomas Staff answered 2 months ago

Hello!
 
Thank you for the message! I just tested Magio Pro on Unity version 2022.3.12f1 Visual effects graph 14.0.9 and I cannot reproduce the error you are getting. In other words, everything runs as it should. Could be an issue with that exact version. Or something with the urp template you are using?
The steps I followed:

  • Installed Unity 2022.3.12
  • Created a new project with standard URP template
  • Installed Visual Effects Graph
  • Imported Magio Pro
  • Opened Demo Scene
  • Pressed Play

I hope this helps and you get it working 🙂
All the best,
Thomas

Thomas Staff replied 2 months ago

To add: the error comes from->
if (!magioEff.HasMesh(“Magio_Mesh”))
{
Debug.LogError(“IF you are getting this error when importing Magio for first time, Please install Visual Effects Graph and Re – import Magio Folder(Right – click->Re – import). Otherwise: Effect invalid for meshes. Please check that your effect has property called Magio_Mesh”);
return;
}
This means that if the Visual Effects Graph is unitialized (in case of built-in effect), it cannot find the property.

TAKASHI ISHIDA replied 2 months ago

Thank you very much.
I upgraded to Unity 2022.3.16f1 on a new project.
I installed Magio and it works fine.
Unfortunately, however, it still does not work on my project, so I will give up using it on my current project.

TAKASHI ISHIDA replied 2 months ago

Thank you very much.
I upgraded to Unity 2022.3.16f1 on a new project.
I installed Magio and it works fine.
Unfortunately, however, it still does not work on my project, so I will give up using it on my current project.

Your Answer